何かやってみるブログ

興味をもったことに関して書いています。技術系の記事が多いです。

jets deployした時にbyebugとpumaのlambda gemsのコンパイルエラーが発生した時の対処法

概要

qiita.com

上記の記事を読みながらjetsを試していて、jets deployする時gem関連のエラーにハマったのでメモに残します。

実行環境

  • ruby 2.5.0
  • jets 2.3.16
  • byebug-11.1.3
  • puma-4.3.5
  • mac OS Catalina 10.15.4

解決法

pumaのバージョンを4.3.3にダウングレード byebugのバージョンを11.1.2にダウングレード

上記の設定をしてbunlde installし直して、jets deployすると無事にlambdaを作成出来ました。

参考にしたissue

github.com